Anker 20000 USB port not charging, no led lights when button is pressed

Hello all,
My Anker 20000 stopped working after about 5 years. The leds on the power bank light up when plugged in for charging the power bank. With the power bank fully charged, when a USB cable is plugged to charge the device, the leds aren’t turning on and the device isn’t charging either.

Tried pressing the button when the device is plugged in to trigger charging but the leds aren’t turning on. The power bank leds are turning on only when the power bank is plugged in for charging. Is my power bank dead? Any help is appreciated.


Yes probably dead given the age.

But you can try:

  • try different USB cable.
  • reset it? Connect the output to the input and press the power button.

After trying both, if still not working then it’s died after a long glorious life.

1 Like

Are you sure that it is fully charged? what is the rating of the power plug you are using to charge it?

Also try looping a cable from the usb port to the charge port on the battery pack and leave it for about 10 seconds, this will reset the internal mechanism in case anything was tripped causing it to not work

1 Like

It’s fully charged. All 4 blue leds light up when plugged in for charging. Tried looping. Doesn’t work.

Tried different cable and reset approach. Didn’t work. Probably dead :confused:

Seems so.

If we helped at all click the solution button lower right on all that helped.

1 Like