After connecting my Liberty air 2, left mic is not working

After connecting my Liberty air 2, left mic is not working my i can hear music from both of them ?
Is this technical issue or there are any settings to change

Please tell us the device you paired with. Thank you.

Samsung Galaxy Note 9

You should wait a little bit, the friends who got such a device will show up later (local time)
and give you hints I am sure.

Maybe there is an update that can fix this

Have you tried resetting Air 2?

When you pair these you need to first take out the right one, go to bluetooth settings and connect it and wait for it to ask to pair, then take out the left one it should pair with the right one (the main), also check and see if it is asking to pair. NOTE: This is the out-of-box setup, to RESET them to this state, take them out of the case make sure they power on, put them back in the case and leave the lid open, with lid open hold down the button on the back for 5 seconds until the buds flash red, then they are reset, start from the top. GL!

You also facing this same problem ?

yes no use

tried it brother, but no use only getting the audio or music from both of them

And mic is responsive only from one ( which one i connect first)

Are your buds are okay ?

I had such ones, but I donated ti to my son.
As far I know these are still OK.

Can you ask him after the current firmware
Can he use both microphone simultaneously ?

Sorry I don’t get live notifications from this Forum for whatever reason, Yes, long story short mine are fine. If you have done all of that then email and tell them all the step you have taken and that you tried asking here too. They should skip to possibly replacing them, if there are no other extra troubleshooting actions that I don’t know. No I did not have the same problem, but I have read the same sort of post a bunch of times, so I know what you need to do.

the same problem here, is this not related with latest firmware upgrade?

Same problem here, is this not related with latest firmware update?

1 Like

I’m afraid not. When did you purchase them? From what I could tell there were some faulty ones that went out when they were first released. If yours were working before the firmware update then you may be dealing with something different. This is the general troubleshooting:

Total Reset
  • Place Both earbuds in the case ensuring they are “charging”(lights are on)
  • Leave the Lid open, press and hold button on back
  • Earbuds will flash red, they are fully reset

If you still have issues email with your order # and they will help.

Actually I did it, but still the same… I just sent an email to support… I purchased last year… but again, I never noticed this with microphones…