About Anker Powercore 20100 switch edition


Bought the switch edition 20100 powerbank and Anker PowerPort II Dual Port 49.5W USB-C Wall Charge recently. I tried to charge the powerbank using the PowerPort II, it works at first but could not work after a few hours of charge which is not blinking and the powerbank only has 3 lights lighted up only. The powerbank still can charge my phone or the switch, but lights not blinking when charging using PowerPort II. Any1 could help to rectify this issue?

Thanks in advance.

Are you using the PD port with the supplied USB-C to C cable?

Hi. Yes I am using it from the Powerbank package itself

1 Like

I have the smaller switch edition and the supplied cable stopped charging mine within a week or using it. So i recommend trying to use a different cable to charge it.

The problem is most likely the cable the most common failure point. If a new cable doesn’t solve the problem try resetting the powerbank by useing a USB type A to type C to connect the output the the input for 30 seconds. Don’t worry about damaging the powerbank they have many protections built in.

Ok i will try later and update. Many thanks!

1 Like

I checked and i think the Powerbank USB C port maybe faulty. I tried to charge my Switch and it is not charging using Type C to C USB, whereas it works for type A to C. Tried to charge to powerbank with nintendo switch cable also cannot work. I found from the owner manual that the powerbank is not compatible with PowerIQ, PowerIQ 2.0 or Qualcomm Quick charge, as i am using Anker PowerPort II Dual Port 49.5W USB-C Wall Charger to charge the switch. Is it this reason that the USB C port on powerbank is faulty?

1 Like

The usb c port is two way, maning you can charge it from the USB-C and also output power…but in order for it to output power you need to press the power button before plugging in any cable to it, This way it will charge your device and not try to draw power from it

hmm ok i tried using the type c to type c and try charging my switch and press the power button, but does not charge. I tried the same cable (Type c to type c) to charge my switch via the power core and it works. Probably the powerbank type C port is faulty

1 Like

Reach out to support@Anker.com

i think im i had the same problem, maybe i’ll just wait for an answer

1 Like