A7722 Keyboard will pair but no type in IOS 11.0.X

Has anyone had an issue where the A7722 keyboard will not function with iPad Air 2? The keyboard will pair with the iPad, but will not type on the screen even though it says it is connected.

Haven’t noticed any issues while running the public beta’s with the keyboard. Is it not typing in certain apps or any? Have you tried a clean pair with the iPad or is it a previous pairing before iOS update?

I am having the same issue. Sometimes it works, but mostly doesn’t. Have tried forgetting the device then reinstalling on iPad Air 2. Worked first time, but now has stopped. Please help!

I have two Ipad Air 2, both iOS 11.2.1 and neither seem to be able to pair with my A7722 keyboard anymore. I see keyboard in setup, click on it, it gives me 4 digit code to enter but it never successfully pairs. Blue pairing light is on, fully charged, and it has worked in the past. Love the keyboard and would like to use it again (it’s been months since I used it and it DID pair at one time). I’ve tried existing pair (no success) and deleted the keyboard and tried to re-pair and no success. A response to this thread would be nice, or a point to a thread with the solution.

I know a lot of people are having bluetooth issues and it has more to do with ios and their updates than the keyboard itself. What apple has recommended is forget the device, reset your network settings, repair the device…if that doesn’t work then forget the device, turn bluetooth off and hard reset your device and try again

Thanks for the suggestions. Tried every combination of deleting/forgetting keyboard in settings, turning bluetooth off/on, turning iPad off/on, and saying a prayer, but nothing seems to help. IPad appears to see the keyboard but doesn’t want to pair anymore. Guess I’m gonna have to look for a new keyboard…ugh…love my iPad but it’s getting too expensive to keep up with technology. Talk about a throw-away world! So sad…