30C starts cleaning, then stops - battery 1/2 charged, no error, not stuck, does not return to charger, just stops

My Eufy 30C has been working fine since I bought it almost 2 years ago. Lately, it will start cleaning, but then it will just stop. The app shows no error. The robovac is almost always in the middle of a room, not stuck around or under anything. The charging pad is in the same room and the area around it is clear (and it’s on a light color hardwood floor). In cases when the floor has noticeable debris on it, I can tell that the device has not finished cleaning the room so the scenario is not that the device has finished its cleaning task and has just failed to return to the base.

The battery is still half charged so it has not run out of power while cleaning or while trying the find the charging base. Even though the battery is still half charged, the robovac is not connected to the network and it reports offline in the app.

Note that when the device is charging normally and on the charging pad, I can take it off the charge pad, place it anywhere in the room and use the app to tell it to go home. It always finds the charging base and successfully docks on it no matter where in the room it starts from. So it does not appear that this issue has anything to do with a problem to find the charging pad. Also, this is the same room that my wifi router is in, so the issue is not due to a weak network signal.

Pressing the power button in this situation will not turn the robovac back on. I have to manually place the robovac onto the charging pad and at that point, once it starts chargnig, it will reconnect to the wifii and show me the status in the app (i.e. that it is now “charging” and that the battery level is approximately already 50% charged).

How can I troubleshoot this further to figure out why my robovac 30C will not complete a cleaning cycle and return to the charging base?

Have you tried to unplug the battery and to plug it after > 30 sec.
This should do a hard reset.
My be that helps.

Is there any way it can be reset?

Yeah, I have the exact same problem with the same model robovac. I tried all kinds of things and still have not figured it out .

Have you disconnected the battery?
Often helps, because this is a real hard reset.

I have the exact same problem with the same model. It sounds like a defect on this specific model.
The robot freezes and doesn’t react to the power button. But if I push the robot for about 1 meter it comes back to life with half battery level and I can send it back to the base. This started happening about 1 month ago, so at about the 2 year mark as well like yours.