26800 PD Power Bank not charging

Good day

I live in South Africa and unfortunately there is no support (only in Middle Africa) to contact. I have had my power bank for two years (it’s the 26800 USB C PD Power bank).

For some reason it stopped charging when I plug the cable in. I tried a different usb c cable and the same thing happens. I also tried to connect the USB C to one of the normal USB outputs to reset it. The small amount of charge that is left does work though and lights up, but the moment I try and charge there are no lights.

I am not sure of who to contact here or who is qualified to do repairs, please assist?


I would try this page potentially. There is also a number at the bottom for contact us that has a number for Africa. I think if you have a qualifying warranty that they would maybe have you send it back or send you a new one. It would just depend on your situation.

I do not know of them having somebody to fix a power bank by a repair specialist. (although I could be wrong as well on this)
Plus I would figure with the power banks they would not want somebody to fix it to find out that it would explode on you afterwards (just my guess)

The only idea which you not mentioned is to try a different charger, I think you need a 27W minimum for this Powercore but a 18W PD or IQ3 may also work.

I believe it’s out of warranty by now