2021 12.9” iPad Pro thinks headphones are plugged in with Anker PowerExpand Thunderbolt 3 dock

Hey guys, I have a really strange problem that I’ve been trying to resolve all day. Basically, when the Anker dock is connected to my 2021 iPad Pro via the ThunderBolt 3 port (this is the port on the back of the Anker dock that delivers 85W of power and data), my iPad thinks that headphones are attached to the dock! There is a headphone jack on the dock, but I don’t have any headphones connected! The iPad says its connected to headphones “Realtek USB2.0 audio.”

I’ve tried numerous things (via research on YouTube and the internet at large) to get the iPad to realize there aren’t any headphones attached to the dock, but I’m on the verge of giving up and returning the dock. I also tried Apple support, but it’s not their device so they won’t touch this problem. Anker support says they haven’t heard of this issue before, but I’m sure I’m not the only one with this problem using the Anker ThunderBolt 3 dock with the new iPad Pro thunderbolt port. The dock is otherwise great, but I just can’t seem to resolve this issue and of course it creates a major problem.

I greatly appreciate anybody’s suggestions that could help to resolve this problem!