2 mth old Anker powercore Speed 20000 PD suddenly won't recharge

I’ve been using my macbook pro usb-c wall charger to recharge the Powercore with no problems until 2 days ago it just didn’t recharge anymore. Normally the lights would be blinking when charging, but now it’s just a blank

Is my USB-C port on the Anker dead?

I’ve tried the anker usb-c cable and apple’s usb-c cable to no avail.

The regular usb-3.0 port still works, but the USB-c port doesn’t even output a charge when i try to connect it to my macbook pro.

Is there a way to reset the unit?

Sorry that you’re having issues with your PowerCore Speed 20000 PD. Since you have tried other cables to no avail, might I suggest looking at the port itself? Perhaps there is lint stuck in there? If this isn’t the case, then I suggest you contact Anker support at support@anker.com . Hope it’s just the lint issue but if not, I’m sure Anker will get you thru it, if not, exchange it out for you. :slight_smile:

1 Like

In order for your batterypack to output a charge via the USB -C port you need to press the button before you okug in any cable

Contact customer support, Anker is great in addressing customer concerns. There is no need to post about this issue and this is your first post…seems fake to me.

I’ve already sent an email to Support@anker 2 days ago and they have yet to reply to me.

Why would this issue be fake?

I thought I could get some support here quicker than Support@anker. Like maybe how to reset the powercore

@Nathan_Wu While your waiting for a response from @AnkerSupport try the following;

  • make sure button has been pressed before connecting your USB-C device that requires charge
  • make sure the PowerCore’s USB-C port is free from blockage such as dust or lint (air duster works well)
  • try a fresh USB-C cable (if you have one to hand)
  • loop the standard USB port to the USB-C port (using a USB-C to USB-A cable), this often works as a reset on several other PowerCores…
1 Like

Try switching out your wall adapter maybe?