2.4GB Ergonomic Mouse unresponsive on Windows 7


I recently bought the Anker ergonomic mouse but it is unresponsive. I plugged in the USB into my Windows 7 laptop and nothing happens. The red light flashes on the mouse for a few seconds but that’s it. I’ve bought brand new batteries and changed them twice.

Anyone have any idea what the issue is?

Have you tried using a different usb port? I would recommend unplugging it and once your laptop is booted up fully try plugging the usb receiver back in and seeing if windows makes a ding sound, if it does then you know it recognizes is and is looking for drivers to install. If it doesn’t make any noise when you plug it in, then go to your settings and make sure you have plug and play turned on. And try again


Try another USB-port first, if nothing happens again I would recommend
to take a look what the system information (sic) tells you about the USB-port to check if the dongle is recognized.

WIN7 is pretty old.
What about an upgrade?

If your computer is really an “old one” and not compatible with newer WIN distributions, I would go for LINUX.:wink:

1 Like

Windows 7 is not that old, also many people prefer that over windows 10. Nothing wrong with using either or, it just comes down to personal preference. I myself use Windows 7 on my desktop and windows 10 on my laptop. Oh, I also have a laptop with windows xp…but that’s just to program my car and do certain tuning of my ecu.

1 Like

I’m always a little skeptical with WIN.
They need to sell their new OS, so they might stop to release patches for the older OS’ whenever they want, even there is no need.

But I remember WIN7 was really usable, when having it installed years ago :grin:

1 Like

@alexs17 Have you tried to use a different USB port? Meanwhile, we suggest you test the mouse on another device for double confirmation. Hope this helps. If this issue cannot be fixed satisfactorily, you’re welcome to contact us via support@anker.com and we’ll surely do our best to help.