16 minute delay for EufyCam notification

I have the original Eufycam with 2 cameras. I finished installing and testing my first Eufycam with out any issues and I just got the second camera mounted and ready for testing. When I ran the test the camera recorded just fine but I did not get a notification. After waiting about 16 minutes I finally received the notification. Maybe the Eufy notification server is having issues. This was around 5:06 PM on 12/23/2019. Did anyone else experience something similar about that time? I’m only writing this because I have never had a delay before that I know of. Hey Eufy, do you have any answers?
Update: 12/23/2019 at 8:00 PM
I read that some Eufycam users have had this issue and were able to fix it in the EufySecurity app by deleting and reconnecting the camera. Unfortunately, I did that and now I get no notifications, so I gave up until the next morning to call support for help.
Update: 12/24/2019 at 7:30 AM
I ran another test and this time got a notification about 5 minutes later which is better then nothing. Unfortunately, when I called Eufy support I found out they took the 2 days before Christmas off. Great, I’m leaving on a trip the day after Christmas for 3 weeks. Hope they can repair this without me needing to do something on my end!!!